Inconvenient Quirks of LibreOffice 3.5

Firstly, let me acknowledge that my operating system is somewhat dated. Not outdated (as in obsolete), but not the newest and brightest version. Consequently, some of my software are older versions. I’m not sure if what I’m about to write has been corrected in an updated version of LibreOffice or not. I certainly hope so, because for eBook publishing as .doc files, it’s the best Ubuntu has to offer.

The problem? This

LO culprit1It’s that little paragraph mark that you wouldn’t even see unless I clicked on the “Nonprinting Characters” button before taking my screenshot.

LO_culprit3

This is actually a very useful tool for an author, because it shows me the formatting of my document: spaces between words (or extra spaces), paragraphs, tabs (a no-no in eBook publishing, we’re supposed to use styles), stuff like that.

The problem is that the paragraph symbol is supposed to look like this

paragraph_symbolCan you see the difference? In the first photo the circled paragraph symbol is underlined and dark blue like the links are. In the last photo it’s plain black. What I have figured out is, that when it looks like a link it creates problems with whatever follows. It’s not a link, but somehow it influences the next paragraph when the eBooks are published.

One problem I’ve had is that the entire paragraph following such a symbol will have blue, underlined text. It doesn’t link to anywhere, but the formatting is the same as a link. Recently I encountered a new problem. Smashwords sent me a notice flagging ePub navigation issues with the table of contents in one of my Little Series books. For awhile I was stumped. All the links worked in my .doc file, so what was the problem in the ePub version? I finally realized that it was one of those blue underlined paragraph symbols. One of them was in the table of contents and the chapters following were the ones with issues. Once I corrected that, the problem was solved.

How do those paragraph symbols get that way? They happen every time I hit “enter” after linked text. Usually I put the links in last, but it happens if I’m updating or correcting.

So I’ve learned to check all my paragraph symbols before uploading a file for eBook conversion. After many hours of frustration, it’s a relief to finally find the answer. Hopefully the newer version of LibreOffice won’t have this problem.